Skip to main content
Skip table of contents

Revit Add-On Installation

Revit versions supported by dRofus

The following Revit versions are supported and all versions supported by Autodesk:

dRofus version / Revit Version

2019

2020

2021

2022

2023

2024

dRofus 2.12

dRofus 2.11

dRofus 2.10

dRofus 2.9

dRofus 2.8

dRofus 2.7

dRofus 2.6

dRofus 2.5

Installation

The dRofus Add-On for Revit is automatically installed with the dRofus Client. If you have an older version of dRofus installed, please make sure Revit is closed, then download the latest version from here and install (or install from the link if this is provided). If you are running a Revit session at the time of installing dRofus, you may get a message asking you to first close Revit.

After the installation, log in to the dRofus Client. The Add-On will then be automatically installed and available with the following dRofus menu/ribbon the next time you start Revit:

Whenever there is a version update to dRofus, you will be asked to click on the "restart the application now" button within the Client. Again, if you click on that button and you happen to have a Revit session running at that time, you will get a message asking you to first close Revit:



JavaScript errors detected

Please note, these errors can depend on your browser setup.

If this problem persists, please contact our support.